Back to overview
Downtime
PowerSchool and Odoo Outage
Aug 17, 2025 at 01:28am UTC
Affected services
Powerschool
Odoo
Resolved
Aug 17, 2025 at 03:14am UTC
Availability has been restored for Odoo and PowerSchool.
Affected services
Created
Aug 17, 2025 at 01:28am UTC
PowerSchool and Odoo are being affected by an issue and are not currently accessible. The IT team is aware of the issue and is working to resolve it.
Affected services