Back
Degraded

Partial Restoration of Service

Started 8 May at 02:00pm GMT+4, resolved 8 May at 10:41pm GMT+4.

Print Service
Resolved

All campus internet services have been fully restored. Thank you for your patience during this outage.

Posted 8 May at 10:41pm GMT+4.
Updated

We are continuing to troubleshoot the outage, which is affecting ES, ELC, and select other areas. Please work in an unaffected area or use a hotspot until we are able to resolve the issue.

Posted 8 May at 03:24pm GMT+4.
Updated

We are continuing to troubleshoot the outage, which is affecting ES, ELC, and select other areas. Please work in an unaffected area or use a hotspot until we are able to resolve the issue.

Posted 8 May at 02:52pm GMT+4.
Created

We have restored internet for MS and HS, but ES and ELC are still affected. We are in the process of implementing a fix, but do not yet have an ETA for when the fix will be implemented.

Please click on this message to see the latest updates.

Posted 8 May at 02:00pm GMT+4.