Back to overview
Downtime
Campus-wide internet outage
May 08, 2025 at 08:29am UTC
Affected services
Print Service
Resolved
May 08, 2025 at 09:50am UTC
Service in MS and HS has been restored.
Affected services
Updated
May 08, 2025 at 08:38am UTC
Internet service has been restored in HS, MS, F Block, and B Block. We are working on restoring service to ES.
Affected services
Created
May 08, 2025 at 08:29am UTC
Campus internet is currently experiencing an outage. The IT team is aware of the issue and is working to restore service. PowerSchool, Odoo, Schoology, and Google are still accessible if using a personal hotspot.
Affected services