Back
Maintenance

Scheduled maintenance on PowerSchool

Completed 13 Dec at 09:00am GMT+4.

Powerschool
Completed

Maintenance completed

Posted 13 Dec at 09:00am GMT+4.
Started

We are conducting maintenance on PowerSchool starting today at 9:30 AM, December 12th until tomorrow 9 AM, December 13th. PowerSchool will not be accessible during the maintenance period.

Posted 12 Dec at 09:30am GMT+4.