Back
Downtime

PowerSchool Outage

Started 30 Oct at 09:25am GMT+4, resolved 30 Oct at 09:33am GMT+4.

Powerschool
Resolved

Access to PowerSchool has been restored as of 9:28am. In the event that need to conduct scheduled maintenance in the evening or after school, we will post an announcement visible when you are logged into PowerSchool.

Posted 30 Oct at 09:33am GMT+4.
Created

Dear Faculty and Students,

Powerschool is being affected by an issue that is causing it to be inaccessible. The IT team is aware of the issue and is working to resolve it.

We apologize for the inconvenience and will post further updates to https://status.asdubai.org hourly. We will send an email again once the issue has been resolved.

Posted 30 Oct at 09:25am GMT+4.