Back
Maintenance

Scheduled maintenance on Powerschool

Completed 12 Oct at 04:00pm GMT+4.

Powerschool
Completed

Maintenance completed

Posted 12 Oct at 04:00pm GMT+4.
Started

Powerschool will be unavailable today from 12:30PM to 4:00PM.

Posted 12 Oct at 12:30pm GMT+4.