Back
Maintenance

Print service partial outage

Completed 19 Sep at 10:13am GMT+4.

Completed

Our print service is back online. A fix was implemented at 9:30 AM and we finished testing at 10:00 AM. Thank you for your patience.

Posted 19 Sep at 10:13am GMT+4.
Started

[UPDATE]: The IT team has implemented a fix and is in the process of visiting each printer to verify connectivity.

Our print service is currently unavailable on the Epson printers. Printing in the copy center and direct printing in the department offices are available.

We apologize for the inconvenience and are working to resolve it as soon as possible.

Posted 19 Sep at 08:00am GMT+4.