Back to overview
Downtime
Phone service restored
Aug 29, 2023 at 11:03am UTC
Resolved
Aug 29, 2023 at 11:52am UTC
All services have been restored.
Affected services
Created
Aug 29, 2023 at 11:03am UTC
The campus phone system has returned to normal operation.
Affected services