Back
Downtime
Downtime
Outage on various services
Started 29 Aug at 02:32pm GMT+4, last updated 30 Aug at 08:53am GMT+4.
Powerschool
Updated
All services have been restored.
Posted 30 Aug at 08:53am GMT+4.
Created
A power issue on campus is causing interruptions in some of our services. Our facilities and IT teams are working to restore normal operations. The affected services include:
• When connecting to WiFi, you may experience an "Authentication failed on network" error. After dismissing this error, your laptop will then connect normally.
• On-campus phones are currently down
• The Self-Service app and new laptop registration is not available
Other services are running normally.
Posted 29 Aug at 02:32pm GMT+4.