Back
Maintenance

Planned Internet Maintenance, Thursday 3-3:30pm

Completed 17 Aug at 03:30pm GMT+4.

Powerschool
Completed

Maintenance completed

Posted 17 Aug at 03:30pm GMT+4.
Started

In order to replace core equipment used to run our school network, the IT team has scheduled maintenance this Thursday, Aug 17 from 3 to 3:30pm. During this time, the school's internet connection and WiFi may experience outages. We will complete the maintenance as soon as possible.

If you plan to work on campus during this time, you may use a phone hotspot to connect to the internet. Google Workspace and Odoo will be unaffected by this maintenance, but PowerSchool and printing will be affected.

Posted 17 Aug at 03:00pm GMT+4.