Back
Maintenance
Maintenance
Sign-In Issues
Completed 4 Jun at 10:00pm GMT+4.
Completed
Maintenance completed
Posted
4 Jun at 10:00pm GMT+4.
Started
We are currently investigating issues with using Google to sign in to several ASD apps, including Canva, ArcGIS, and Adobe Creative Cloud. Core services such as Google Workspace, Schoology and PowerSchool are unaffected. We are worked to restore normal service and will post updates here when available.
[Update 10pm June 4] The issues for Canva, ArcGIS and Creative Cloud has been restored.
Posted
4 Jun at 08:15pm GMT+4.