Back
Maintenance
Maintenance
Digital Signage Software Update
Completed 15 May at 09:00am GMT+4.
Updated
Digital signage is back online at 9 AM. If you find any digital signage that are offline, please report it to the IT department. Thank you.
Posted
15 May at 09:49am GMT+4.
Completed
Maintenance completed
Posted
15 May at 09:00am GMT+4.
Started
Our digital signages are experiencing issues and we are currently applying software updates to mitigate the issues.
Posted
15 May at 08:00am GMT+4.